Issues with Timesheet Entries
Incident Report for Shiftie
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 13:43 GMT
Monitoring
A fix has been deployed and we will monitor for regressions over the next few hours.
Posted Feb 20, 2024 - 11:47 GMT
Update
A fix has been deployed for automatic clock-outs and functionality has been restored. You may observe timesheet entries having a later clock-out time than would be expected. This can be rectified by manually modifying affected timesheet entries.

The window for affected timesheet entries is 12:00 GMT -> 16:00 GMT on 20/02/2024.

---

Unfortunately, during internal testing of the UI fix, some further issues were found. We're still working on getting this resolved ASAP, although a fix is now not expected for deployment until 10:00 GMT 20/02/2024.

In the meantime, a temporary workaround is to refresh the page when a timesheet entry is created, updated, approved, or otherwise modified. This will restore the UI temporarily until another entry is modified.

Again, we apologise for any inconvenience this may have caused. We will be in contact, where necessary, with any companies affected by today's issues.
Posted Feb 19, 2024 - 18:19 GMT
Update
A fix has been implemented for the original UI issues and is currently being tested internally.

We have identified another issue, which is prevent automatic clock-outs for scheduled shifts. A fix has also been implemented for this and is being tested internally too.

Another update will follow at 17:00 GMT.
Posted Feb 19, 2024 - 15:57 GMT
Identified
We have identified an issue with the timesheet entries page where functionality including approving, creating, and updating records results in an unstable user interface (UI).

We apologise for any inconvenience and appreciate your patience as we work diligently to implement a solution.
Posted Feb 19, 2024 - 13:26 GMT
This incident affected: Shiftie App.