Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 28, 2026 - 21:00 GMT
Scheduled
Scheduled system downtime to upgrade our storage databases will occur on Wednesday, 28th January, between 21:00 and 21:30 (GMT). If you have any issues, please contact our support team.
Posted Jan 28, 2026 - 09:13 GMT
This scheduled maintenance affected: Shiftie App, Shiftie API, Clock In Portals, Integrations and Content Delivery (Public Files, Private Files).